Geçtiğimiz haftalarda WordPress’in sistem çekirdeğinin geliştiricilerinden biri olan Matt Mullenweg bir duyuru yaptı ve WordPress 4.8 sürümü ile hangi tarayıcılar için geliştirmelerin yapılacağına ya da yapılmayacağına dair bilgiler verdi. Yapılan duyuruda herkesin beklediği gibi artık WordPress, İnternet Explorer 8,9 ve 10 sürümlerine yönelik geliştirmeler yapmayacak hatta geliştirmelerin tamamen durdurulduğunu belirtti.

WordPress 4.8 Sürümü İle İnternet Explorer İçin Desteğini Bitiriyor!

Bildiğiniz üzere Ocak 2016 tarihinde Microsoft,İnternet Explorer‘ın eski sürümlerine desteklerini kestiğini açıklamıştı. WordPress’in geliştirici ekibinden olan Matt Mullenweg yaptığı duyuru da buna dikkat çekmiş ve internet explorer’ın eski sürümlerine artık destek verilmeyecek. İlgili blog yazısı için buraya tıklayınız.

Microsoft Edge İçin Geliştirme Desteği Devam Edecek!

WordPress’in blog yazısında bahsedilen bir diğer husus ise bu kararın sadece eski sürümler için geçerli olduğunu ve Microsoft’un yeni tarayıcısı olan Microsoft Edge için geliştirmelerin devam edeceği  yönünde.

Mullenweg’in dediğine göre internet explorer’ın bu eski sürümlerine yönelik geliştirmeler yapılması WordPress’in geç kalmasına ve yavaş gelişmesine sebep oluyor. Buna ekleme yaparak; “Zaten WordPress’i  internet explorer ile kullanan internet sitesi sahipleri %3 dahi geçmiyor. Bu kadar az kullanılan bir tarayıcı için geliştirme yapmak ne kadar doğrudur ?”  Mullenweg bu istastistiki veriyi GlobalStats‘ın verilerine dayandırmaktadır. Bu veriler ışığında İnternet Explorer 8,9,10 ve 11.sürümlerin dünya genelinde kullanım oranları:

  • IE8 0.41%
  • IE9 0.26%
  • IE10 0.26%
  • IE11 3.79%

Yapılan blog yazısında sadece kullanım oranlarına dikkat çekilmiyor. WordPress 4.8 sürümü ile birçok yenilik ve geliştirmeler olacak deniyor ve ie bunların hiçbirini destekleyemiyor. İE’nin destekleyemediği özelliklerden bir tanesi ise WordPress’in 4.8 sürümü ile daha fazla özellik ekleyemeyi düşündüğü yazı editörü olan TinyMCE  editörü var. Bu editörü geliştiren ekip çok uzun zamandır ie desteği vermiyordu. Bundan dolayı da Mulllenweg, yaptığı duyuru yazısında “ie desteğini çekmemiz kaçınılmaz bir şeydi.” diyor.

Yani anlayacağınız arkadaşlar ie’ye bir darbe’de WordPress’den geldi diyebiliriz. Zaten internet explorer’ı geliştiren Microsoft’ın en başarısız işlerinden biri olan ie’nin sonu hiç iyi gözükmüyor. Edge’si var demi Microsoft’un anaa.. onu unuttum ya la ben, ie’nin kılıf değiştirmiş hali idi ona güveniyorsanız ondan da bi bok olmaz açıkcası yakında onunda fişini çeker Microsoft 🙂

Bir önceki yazım olan WordPress Tema Yapımı ve En Sık Kullanılan Fonksiyonlar başlıklı yazımda WordPress Tema Nasıl Yapılır ? ve WordPress Tema Yapımı hakkında bilgiler verilmektedir.

1 Yorum Mevcut “WordPress 4.8 Sürümü İle İnternet Explorer Desteğini Bitiriyor!”

  1. Edge için devam edecekse sorun yok, zaten eski sürümler tırt kullanmasın artık kullanıcılar.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir